NEO Team's Projects for the GBA/NDS/NDS lite > NEO GBA/NDS software and driver downloads

Bricked Neo2 Pro?

(1/3) > >>

I just recently bought a Neo2 Pro, but I haven't had much luck getting it to work. I'm starting to think it might be bricked or defective in some fashion.

Whenever I try flashing a ROM to the Neo2 Pro's ROM, Neo2 Ultra Menu will say "Not enough ROM!" even though there should be 1024M of ROM available. If I try to use Neo2 Manager to flash a game to it, it says "No Neo2 Cartridge!"

When formatting the card, no matter what format speed is selected, it acts is if it is performing a fast format. The menu, however, seems to format fine through Neo2 Ultra Menu, but there is no way to flash a game to the card...

Does anyone have any ideas on what I can do to fix this problem? I've tried different programs, drivers, and even operating systems, but I had no such luck.  :-\

First, current systems can only write half the flash on the Neo2-Pro, not all of it. I imagine this will be addressed in time. You cannot use the Neo2 Ultra Menu to format/write to the Neo2-Pro since it thinks it can write the whole thing.

You need to use the Neo2 Pro Manager. The latest version available to folks is v1.0.3, but if you only install the v1.0.3 package, it won't write the Neo2-Pro correctly due to issues with some dlls. Updated dlls were released further in the thread, so you need to go through the thread and get all the updated dlls to copy over the ones in the installer package.

If you've done all that correctly, 512 Mbits of the Neo2-Pro will write correctly.

Thanks for the quick reply!  ::sm-15.gif::

I updated both the Neo2Menu2.dll and PlugDemo.dll as they did need updating; however, my problem persists. Neo2 Pro Manager still says "No Neo2 Cartridge!" Any ideas?

Some GBA carts don't press against the contacts in the connector very well. It helps to put a label on the opposite side to help push the edge against the connector. I have a Neo2-SD that used to always say no cart, but the label fixed it right up.

I gave the label idea a shot after cleaning the contacts on the card, but no such luck. :-\ I tried applying different levels of force as well, but the status in Neo2 Pro Manager didn't seem to change... even if I rebooted the program.

Plugging this thing into the SL4 or the N64 Neo Myth gives the same results as well. If it helps to know, I am able to format just the menu through Neo2 Ultra Menu (I know it's outdated) and it does save the changes, but the program acts as if it can't access the ROM part of the card. Also, the card also does boot to a menu if ran on a GBA.

Any other ideas?


[0] Message Index

[#] Next page

Go to full version