Author Topic: NeoMythMenuDX-v2.8  (Read 8264 times)

0 Members and 1 Guest are viewing this topic.

Offline ChillyWilly

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Just a coding machine.
NeoMythMenuDX-v2.8
« on: May 26, 2012, 06:23:29 AM »
Here's the current menu for the MD 3-in-1 Myth. This version features fast SD card recognition - if you don't have an SD card (or using a flash cart without the SD interface), it detects this very fast, so the menu goes to the flash browser almost instantly.

This version also works around a bug in the Neo2 Manager - under some circumstances, the manager doesn't set the run mode correctly when burning games to the flash. The menu will derive a proper run mode in these cases. This mainly affected MD and SMS games with save ram.
« Last Edit: September 22, 2012, 12:43:08 PM by ChillyWilly »

Offline keropi

  • Jr. Member
  • **
  • Posts: 64
Re: NeoMythMenuDX-v2.8
« Reply #1 on: May 27, 2012, 06:05:02 PM »
it's an awesome update, thanks ChillyWilly !!!  ~sm-78.gif~.gif

Offline joyeux

  • Jr. Member
  • **
  • Posts: 56
Re: NeoMythMenuDX-v2.8
« Reply #2 on: May 29, 2012, 07:28:57 AM »
Great work, thank you very much, Chili! All the sram issues are gone, the Save Ram manager now works flawlessly!

Found a possible bug: can't start Sega CD in BRAM mode with SCD_SRAM.bin. Tried CDx and the Sega CD II models, both didn't boot. I noted the Run Mode is: 0x1 - Type MD. Tried burning the ROM by the Myth  Programmer and by Madmonkey's programmer.

Offline ChillyWilly

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Just a coding machine.
Re: NeoMythMenuDX-v2.8
« Reply #3 on: May 29, 2012, 09:19:02 AM »
Great work, thank you very much, Chili! All the sram issues are gone, the Save Ram manager now works flawlessly!

Found a possible bug: can't start Sega CD in BRAM mode with SCD_SRAM.bin. Tried CDx and the Sega CD II models, both didn't boot. I noted the Run Mode is: 0x1 - Type MD. Tried burning the ROM by the Myth  Programmer and by Madmonkey's programmer.

Yes, that's the wrong mode. I may consider ignoring the run mode in the flash altogether - it seems like there's many instances where it's wrong. I'll fix the SCD issue in the next update. That will probably be next weekend to give some time for more bugs to be noticed.
« Last Edit: May 29, 2012, 09:20:39 AM by ChillyWilly »

Offline joyeux

  • Jr. Member
  • **
  • Posts: 56
Re: NeoMythMenuDX-v2.8
« Reply #4 on: June 05, 2012, 09:30:29 PM »
Don't know if this is a bug, but I can't successfully test the psram. Please see attachment.

Offline ChillyWilly

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Just a coding machine.
Re: NeoMythMenuDX-v2.8
« Reply #5 on: June 12, 2012, 03:59:42 AM »
If you run the menu from the SD card, it cannot test the PSRAM where the menu is loaded. You have to run the menu from the menu flash to do that. I thought conle and I worked that out (to save and restore the psram at the menu address), but maybe that was in some test code that didn't make it into the release. I'll check on that.

Offline Christuserloeser

  • Newbie
  • *
  • Posts: 10
Re: NeoMythMenuDX-v2.8
« Reply #6 on: June 21, 2012, 07:26:59 PM »
Downloading the attachment doesn't seem to work for me.

Offline ChillyWilly

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Just a coding machine.
Re: NeoMythMenuDX-v2.8
« Reply #7 on: June 22, 2012, 01:53:08 AM »
Downloading the attachment doesn't seem to work for me.

Probably because of the forum update. When you have trouble like this, check the google page - it's usually there as well.

http://code.google.com/p/neo-myth-menu/downloads/list

In the meantime, I'll fix the attachment.