Neo TeAm Forum

NEO Team's Project for the NeoGeo/SNK => NEO Super MVS Convertor for SNK NEOGEO => Topic started by: shinra85 on November 28, 2014, 03:52:36 PM

Title: MVS Magic Key 2013 not working
Post by: shinra85 on November 28, 2014, 03:52:36 PM
Hello

Got my converter a few weeks ago, but the one MVS-cart I had wouldn't play. I only got a bunch of pink or dark blue squares on the screen. The red lamp on the converter was all red (but green with no cart in the converter).
Just got a new MVS-cart and tried it out, but it's the same deal; pink squares on screen.

What can I do about this? Do I need to return the converter? I spent alot of money on it, and it saddens me when it's not working.

I hope someone can help me with this
Title: Re: MVS Magic Key 2013 not working
Post by: Dr.neo on November 29, 2014, 06:12:53 AM
[1] please tell us what MVS carts you have try?
[2] and do you try to replace a new DC adapter? maybe is the power issue.
[3] please try to use alcohol to clean your MVS carts golden finger.maybe it's too dirty.
Title: Re: MVS Magic Key 2013 not working
Post by: NardBasket on January 27, 2015, 09:22:29 PM
I'm having this exact same issue with the Magic Key I just got yesterday- I plug in MVS games (one of which is brand new) and all I get is a glitchy green screen
Title: Re: MVS Magic Key 2013 not working
Post by: ElkinFencer10 on March 28, 2015, 07:52:32 PM
I'm having this exact same issue with the Magic Key I just got yesterday- I plug in MVS games (one of which is brand new) and all I get is a glitchy green screen
Yup, same here.  Already replaced my power adapter, and I'm still having the issue.
Title: Re: MVS Magic Key 2013 not working
Post by: Dr.neo on March 30, 2015, 03:57:18 AM
what MVS game is it? original or copy?