Author Topic: New PCE flash cart owner here! My report:  (Read 2440 times)

0 Members and 1 Guest are viewing this topic.

Offline ensleepent

  • Newbie
  • *
  • Posts: 2
  • NEO newbie
New PCE flash cart owner here! My report:
« on: September 10, 2011, 01:32:40 PM »
I've had it for a few days now, and still have a lot to try.  I'm not exactly asking for help, just giving my report so far and hoping to encourage discussion.

After spending an afternoon reading through most of this forum, I get the impression that users and developers alike would like to hear more user input.  I know I would.


--The only hardware I have (atm) from the PC Engine family is the USA TurboGrafx-16...  and I have three of them.  Two well-used but working okay, and one in collector's condition, that rarely leaves its original packaging (it still has that "new smell" and everything).

--I also have two used TurboGrafx-CD addons for these machines.  Does this matter?  Keep reading.

--The non-console computers I have in my home now are:  (1) A PowerMac G5 (PowerPC) with OSX 10.4, (2) a decent PC with 32-bit Ubuntu 10.04, and (3) and older -- and fussier -- PC with Windows XP, which is the one I'm using to interface with my new flash cart.

--The flash cart I have is the 128M+Save version.

--I have no rom dumping hardware, so I must rely on the web for my roms.  My HuCard collection is incomplete, anyway.

--I don't have a HuCard converter...  yet.


My WinXP machine didn't like the CD that came with my goodies.  You have all heard this one before.  So I'm using the Neo2 Pro Manager, and it seems to work fine (afaik).

I've been in a shmup mood lately, so the roms I've tried so far are Soldier Blade (U), Gradius, Parodius, and every version of Gunhed/Blazing Lazers that I could find.  I've stripped headers, etc., as necessary.

At first, Soldier Blade was the only one that hadn't crashed on me so far, but still gave me occasional graphics glitches and funny sounds.  Gradius would eventually spontaneously freeze, Parodius crashes blank-screen style somewhere around level 3 or 4 (it's different every time), and the only version of Gunhed/Blazing Lazers that has started at all is the one I found (at numerous sites) named Blazing Lazers [h1], and it always crashes at or slightly after the first sub-boss of stage 1.

No such problems with emulators, so I'm not sure how bad the roms are.

There don't seem to be that many PCE roms out there that are marked with a "[!]" unfortunately.  I should get the hang of verifying them myself.

Anyway, my used TG16s, while in pretty good shape, occasionally require me to reinsert the HuCards at slightly different angles before they load.  It kinda reminds me of the NES, but not so bad.  I never hear anyone mention this problem.  Maybe I just need to crack them open and clean their pins or something.  It hasn't happened often enough to bother me.

My brand-spanking-new TG16 doesn't have this problem though.  So I decided to try it, using the Soldier Blade rom as my test subject.

It runs perfectly, with no fuss that I have seen.

So I stuck it in my TGCD, and I get glitches again.  Pull it back out and run it on its own again, no glitches.  I don't know why, but the flash cart does not like my TGCD addons.

So I tried running it with one of my used TG16s with no CD addon.  Still glitches.

So the flash cart only seems to like my new and pristine TG16, and only when it's not "slumming it" with a dinged-up CD addon.  I wonder what this means...?

Since most of the people on this forum who have been posting complaints seem to be using USA hardware of some sort, I thought this story might be of interest to you.  I don't know how it's useful, though...

I'll keep posting my findings as I keep exploring my new flash cart toy.

And for the record, I'm glad I bought it, and I'm having great fun.

Offline ensleepent

  • Newbie
  • *
  • Posts: 2
  • NEO newbie
Re: New PCE flash cart owner here! My report:
« Reply #1 on: September 17, 2011, 01:46:48 PM »
Since my last post, I've been on a marathon of PCE games with my new flash cart.  And it's been working beautifully.

Once I found which one of my machines it's willing to get along with.

I don't have much to add here, just verification that the flash cart works perfectly...  once it decides that it likes a particular machine.

And the curious observation that it likes one machine, but not the others that are of the same model.  Nor does it like that one machine when it's hooked to a CD addon.

I've heard of many TG16 users here, and at other forums, who have had this problem.  Sometimes.

This must be some sort of clue.  I don't know what it means...  but it's a clue.