Author Topic: Cannot save Pokémon (Moémon) to my NEO Flash cart 1G  (Read 7101 times)

0 Members and 1 Guest are viewing this topic.

Offline Damaged

  • Newbie
  • *
  • Posts: 1
  • NEO newbie
Cannot save Pokémon (Moémon) to my NEO Flash cart 1G
« on: January 17, 2012, 11:58:02 PM »
Hello and good morning :) 

I have really been putting off asking my questions in this forum but I have honestly just ran out of ideas/options/sanity @_@  I will start off with the back story/what I have done to this point.

When I received my NEO Flash 1G carts (I got 2 card and 2 slim loaders so my wife and I could play together) I was wicked excited because the idea of being able to play some of my favorite home brews and/or hacks (E.G. Moémon) on the couch on a GBA just sounded awesome!  That was where the exciting concept started to quickly divulge into unholy nightmare D:

Right away I had problems getting the USB Slim Loader III to be recognized in my computer.  It just would not load.  I did some research and found out that it just does not play nice with newer machines and, more specifically, Windows 7 x64.  So, I tried it on one of my Vista x86 machines.  No avail there either.  So I tried it on my entertainment computer which runs XP SP3 x86.  No dice in there either.

I tried the Neo Power Kit that came with the Slim Loader, I tried Neo Power Max 1.5 and 2.1. I tried Neo Power Kit 2.5 and I even tried the Neo Manager 1.08-1.12.  Nothing worked on any of these 3 machines.  I could not for the life of me get this thing to recognize the device.  So, defeated I started to put everything away when it all of a sudden dawned on me that I had my Mom's old Acer XP sp3 x86 box that I keep to test my own video games on (you know, to see if they work properly on older machines).

It work.  My God it worked.  Neo Manager 1.08-1.12 did not but Neo Power Max 2.1 works and Neo Power Kit 2.5 works.  I can burn games! \o/  Needless to say I was feeling pretty groovy right about now.  That was until I put Moémon on and played it.  Time for a new unholy escapade D:

Before I continue, let me just make it known that I am trying to do all these things at least 4 times.  On both cards with both readers.  Just in case I got me a lemon with one of them.  Also, I want to say that I have read this FAQ (http://www.neoflash.com/forum/index.php?topic=1567.0) about 50 times in hopes I missed something and it doesn't appear that I have.

I can, without issue, get this game and others onto the carts.  What I cannot do is save the game.  Here is what I have tried to both this Moémon game and a proper Ruby game (just in case the hack was causing issues).  Most of this was done in Neo Max 2.1 since it is faster than Power Kit, has more options, it is what the FAQ's are for and Neo Manager never sees the Slim Loader III.  Moving on, here is what I have done.

* Change the saver type.  I have tried all of them (FLASH_M, FLASH, SRAM, EEPROM and none).  Doing this created quite a few different results.  SRAM and EEPROM made the game say that the save area was corrupted and it would go back to default saver.  It would say something like "Time needed was one minute" and then it would fail.  FLASH and FLASH_M would say it saved but upon restart there would be no save.  I have also "Soft Reset" the game and it would have a save but it would say it was corrupted.

* I have tried compressed and uncompressed.  When compressed Moémon won't load but Ruby will.  Uncompressed they will both load.  Still cannot save.

* Changed the S.M.S. memory sizes.  I have tried them all from 56M to 128M (anything below and Neo Max warns that it might not work right).  No saving.

* I have tried GBA mode and NDS mode.  NDS mode makes it so the games will not load.  GBA Mode allows to load but no saving.

* I have tried GST Patch, NDS Patch and No patch.  No Results are the same.

* I have tried making a new Saver instead of Default Saver.  I tired a variety of saving and loading sequences on this like: Loading the game and saving, restarting, creating a new saver, loading that saver, save again, restart, etc etc.  I spent the most time trying different sequences of saving in conjunction with changing the saver type and Rom from Moémon to Ruby.  Regardless of the order, saver, rom or whatever I could not save.  I wasted at least half a day on sequencing along D:

* Neo Power Kit is kind of strange but I tried quite a few different saver options in there as well.  Most of the time is said saver size is 0 but I was able to get it to be Flash 128 a few times. I've tried a variety of saver options with this as well.  Most of the time the write just failed or the game loaded a blank white screen.

* Got a hold of GBATA.  I read somewhere that playing games where the default saver is not SRAM can cause problems.  It was recommended that I used GBATA to change the rom's saver to be SRAM.  So I did.  I don't think it did anything but regardless I tried all the stuff you just read... @_@  Still, no saves.

* Like I said, I have tried this with 2 different carts and SLIM Loaders and sometimes with or without a battery @_@

Okay, that is what I have done and quite frankly, I don't know what to do now.  I'm usually pretty good at figuring out odd problems like this but I have spent so many hours of watching Professor Birch explain to me what a Pokémon is that I just can't do it anymore with out a bit of assistance.  I cannot be the only one that is having saving problems with Pokémon games.

So, here is my question: I cannot get my Moémon/Ruby rom to save on the Neo Flash 1G cart.  Every time I restart my DS (or GBA) I have to select a new game as the save is not there and Professor Birch insists on explaining what a Pokémon is to me.  What do I have to do to get these games to save on my cartridge?

Thank you so much for your time and help!

Mike