Author Topic: CDX Black Screen/SRAM issues  (Read 3618 times)

0 Members and 1 Guest are viewing this topic.

Offline joyeux

  • Jr. Member
  • **
  • Posts: 51
CDX Black Screen/SRAM issues
« on: July 01, 2013, 04:43:47 PM »
Hi! I'm back playing with my Neo Myth MD, and I got strange behaviour with my Sega CDX.

When I insert my setup (Slimloader IV + NEO3SD + MD Menu 2.9b3 + SD Card) in my Sega CDX for a first time, I can choose my game and play it normally. But most times when I press reset in the console or turn off/on, after the "Produced by or under license from Sega Enterprises LTD." it shows a black screen, while the Slimloader led keeps red. Then I need to take the cartridge off the console, wait a few seconds and then re-insert it, and it will boot normally. The detail is that it won't save my last SRAM session, and I will lose save data. Sometimes the Slimloader will hang after pressing reset when the game is running (sometimes freezing the game).

The Slimloader works fine in my Genesis Models 1 and 2, it's just a CDX issue, without losing any data. I've done a lot of tests and it didn't fail in these systems.

I got 2 Sega CDX units, and it presents the same behaviour on both, with diferent power supplies (original ones).

Please help again when possible. Thanks!

EDIT: Simple way to test: Sonic The Hedgehog 3 [!].gen - verified rom. Trying to load this rom starting the game in any save slot and then reseting for 2 or 3 times should cause the issue (all the slots become blank). Tried it with SAVE RAM Manager On and Off, with Return to Game option set (yet the Return to Menu also gives the same problem). 64Kb of SRAM set in MD Menu.
« Last Edit: July 01, 2013, 05:11:24 PM by joyeux »

Offline ChillyWilly

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1751
  • Just a coding machine.
Re: CDX Black Screen/SRAM issues
« Reply #1 on: July 02, 2013, 08:55:13 AM »
I've only seen problems with my CDX if I plug the cart in completely. If I leave it just the TINIEST BIT up, it works without a hitch. For some odd reason, you cannot shove it in until it doesn't go anymore or it doesn't work. Some kinda weird CDX thing.
 ???

Offline joyeux

  • Jr. Member
  • **
  • Posts: 51
Re: CDX Black Screen/SRAM issues
« Reply #2 on: July 02, 2013, 11:22:52 PM »
Yes, I guess you nailed it!

Though I am making more tests to be sure this is really the cause of the problem. I played Sonic 3 until the 3rd stage and my savedata is preserved as the system didn't freez after several resets.

Thank you!

Offline ChillyWilly

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1751
  • Just a coding machine.
Re: CDX Black Screen/SRAM issues
« Reply #3 on: July 03, 2013, 02:11:15 AM »
If I had to guess why, I'd say the CDX socket is slightly deeper than other models. Often you will see lines from the edge that leave the edge finger and then angle off towards another part of the PCB. If the angle is steep (maybe straight sideways) and close enough to the edge AND the socket is deeper than normal, you can wind up accidentally connecting two lines with the socket leaf. Depending on which lines, that could cause strange problems. I've seen similar issues on other consoles and certain carts. It's one of those things that makes engineers' lives more fun.  ??? ;D