Author Topic: Neo2 Flash Card Not Found  (Read 2982 times)

0 Members and 1 Guest are viewing this topic.

Offline joyeux

  • Jr. Member
  • **
  • Posts: 51
Neo2 Flash Card Not Found
« on: February 09, 2016, 09:21:08 AM »
After almost a year resting in the shelf, I decided to put my NEO3 SD in action again.

When I boot it with SD Card (the one that always worked fine), the menu shows the card folders, then the red led lights up and the message "Neo2 Flash Card Not Found" appears in red on the screen. The controls are all locked and I can't access any folder...

The error is also shown when I boot the Myth without the SD Card.

Funny thing is that my Neo Myth works fine with my NEO2 memory only, so I guess this is a NEO3 issue.

Tried cleaning all the contacts, in the Myth, and in the NEO3. When I insert a new SD card, it tries to create the folders, but hangs in the middle of the process with red light on.

What else can I do to try to make it work?

UPDATE: I opened the NEO3 and used some contact cleaning spray and isopropyl alcohol... Now it boots, and reads some folders. I noted the card reader is acting like lazy, when there's a folder with lots of roms, the Myth blinks the green light and then freezes controls. When I enter a two page rom folder, it will read and load the roms. I am inclined to think there is a problem in the cart slot or some related component.

UPDATE 2: It smells like a power issue in the NEO3. Depending of the console I use the Myth, it will or will not work. In the 32X with Genesis Model 1 it will fully work. In the Sega CDX it works nicely. It used to work in most Mega Drives I have, but now there is this problem. And the degree of the problem varies with the console in use... In the Genesis Model 2 + 32X the games will act like crazy after loaded (garbled backgrounds and sounds). With stock Genesis 2 the menu won't boot. With stock Genesis 1, the menu will hang after browsing a folder. All AC Adaptors are Sega original, except for the 32X one.

UPDATE 3: Mega Everdrive works wonderfully in all my consoles.
« Last Edit: February 10, 2016, 04:15:19 AM by joyeux »

Online Dr.neo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3826
Re: Neo2 Flash Card Not Found
« Reply #1 on: February 11, 2016, 11:00:17 PM »
if you doubt it;s power issue, you can use the 9-12V/3-5A dc power adapter to test again, don't use the original sega dc adapter, in this way the power is not enough maybe...
In my world,have 0 and 1 only ......Matrix World......